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1. What is HFSS? 
 

The name HFSS stands for High Frequency Structure Simulator. HFSS is a high-
performance full-wave electromagnetic (EM) field simulator for arbitrary 3D 
volumetric passive device modeling that takes advantage of the familiar Microsoft 
Windows graphical user interface. It integrates simulation, visualization, solid 
modeling, and automation in an easy-to-learn environment where solutions to your 
3D EM problems are quickly and accurately obtained. Ansoft HFSS employs the 
Finite Element Method (FEM), adaptive meshing, and brilliant graphics to give you 
unparalleled performance and insight to all of your 3D EM problems. Ansoft HFSS 
can be used to calculate parameters such as S Parameters, Resonant Frequency, and 
fields. 

 
 
 
 

2. HFSS USES 
 

Typical uses include: 
 

 Package Modeling
BGA, QFP, Flip-Chip 

 PCB Board Modeling
Power/Ground planes, Mesh Grid Grounds, Backplanes 

 Silicon/GaAs 

Spiral Inductors, Transformers. 

 EMC/EMI
Shield Enclosures, Coupling, Near- or Far-Field Radiation 

 Antennas/Mobile Communications
 

Patches, Dipoles, Horns, Conformal Cell Phone Antennas, Quadrafilar 
Helix, Specific Absorption Rate (SAR), Infinite Arrays, Radar Cross Section 
(RCS), Frequency Selective Surfaces (FSS).  

 Connectors
Coax, SFP/XFP, Backplane, Transitions. 

 Waveguide 

Filters, Resonators, Transitions, Couplers 

 Filters 

Cavity Filters, Microstrip, Dielectric. 
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3. Getting Help 
 

If you have any questions while you are using Ansoft HFSS you can find answers in 
several ways: 

 

 

3.1 Ansoft HFSS Online Help provides assistance while you are working. 
 
 

 To get help about a specific, active dialog box, click the Help button in the 
dialog box or press the F1 key.

 Select the menu item Help > Contents to access the online help system.


 Tooltips are available to provide information about tools on the toolbars 
or dialog boxes. When you hold the pointer over a tool for a brief time, a 
tooltip appears to display the name of the tool.


 As you move the pointer over a tool or click a menu item, the Status Bar 

at the bottom of the Ansoft HFSS window provides a brief description of 
the function of the tool or menu item.


 The Ansoft HFSS Getting Started guide provides detailed information 

about using HFSS to create and solve 3D EM projects.




3.2 Visiting the Ansoft Web Site 
 
 

If your computer is connected to the Internet, you can visit the Ansoft Web site 
to learn more about the Ansoft Company and products. 

 

1. From the Ansoft Desktop 
 

o Select the menu item Help > Ansoft Corporate Website to 
access the Online Technical Support (OTS) system. 

 

2. From your Internet browser 

o Visit www.ansoft.com 
 
 

 

4. Ansoft Terms 
 

The Ansoft HFSS window has several optional panels: 
 

i. Project Manager 
ii. Message Manager  

iii. Property Window  
iv. Progress Window  
v. 3D Modeler Window 
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These above managers and windows are shown in Fig (1) and their details are given in 
coming sections. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig (1): Ansoft HFSS window. 
 

 

4.1 Project Manager 
 

A Project Manager which contains a design tree which lists the structure of the 
project is shown in Fig (2). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig (2): Ansoft HFSS Project Manager. 
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4.2 Message Manager 
 

A Message Manager that allows you to view any errors or warnings that occur 
before you begin a simulation is shown in Fig (3). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig (3): Ansoft HFSS Message Manager. 
 

 

4.3 Property Window 
 

A Property Window that displays and allows you to change model parameters or 
attributes is shown in Fig (4). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig (4): Ansoft HFSS Property Window. 
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4.4 Progress Window 
 

A Progress Window that displays solution progress is shown in Fig (5). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig (5): Ansoft HFSS Progress Window. 
 
 
 
 

4.5 3D Modeler Window 
 

3D Modeler Window which contains the model and model tree for the active 
design is shown in Fig (6); model and model tree are shown in Fig (7a) and Fig (7b) 
respectively. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig (6): Ansoft HFSS 3D Modeler Window. 
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Fig (7a, 7b): 3D Modeler Design Tree. 
 

5. Design Windows 
 
 

In the Ansoft HFSS Desktop, each project can have multiple designs and each design 
is displayed in a separate window. You can have multiple projects and design 
windows open at the same time. Also, you can have multiple views of the same 
design visible at the same time. 

 

To arrange the windows, you can drag them by the title bar, and resize them by 
dragging a corner or border. Also, you can select one of the following menu options: 
Window >Cascade, Window >Tile Vertically or Window > Tile Horizontally. 

 

To organize your Ansoft HFSS window, you can iconize open designs. Click the 
Iconize ** symbol in the upper right corner of the document border. An icon appears 
in the lower part of the Ansoft HFSS window. If the icon is not visible, it may be 
behind another open document. Resize any open documents as necessary. Select 
the menu item Window > Arrange Icons to arrange them at the bottom of the Ansoft 
HFSS window. Select the menu item Window > Close All to close all open design. You 
are prompted to save unsaved designs. 
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Fig (8): Design Window. 
 

6. Toolbars 
 

The toolbar buttons are shortcuts for frequently used commands. Most of the 
available toolbars are displayed in this illustration of the Ansoft HFSS initial screen, 
but your Ansoft HFSS window probably will not be arranged this way. 

 

You can customize your toolbar display in a way that is convenient for you. Some 
toolbars are always displayed; other toolbars display automatically when you select 
a document of the related type. For example, when you select a 2D report from the 
project tree, the 2D report toolbar displays, as shown in Fig (9) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (9): Ansoft HFSS Toolbars. 
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To display or hide individual toolbars 
 

 Right-click the Ansoft HFSS window frame.


o A list of all the toolbars is displayed. The toolbars with a check mark 
beside them are visible; the toolbars without a check mark are hidden. 
Click the toolbar name to turn its display on or off. 



 To make changes to the toolbars, select the menu item Tools > Customize.
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (10): Ansoft HFSS Panels and Toolbars. 
 
 
 
 

7. Ansoft HFSS Desktop 
 

The Ansoft HFSS Desktop provides an intuitive, easy-to-use interface for developing 
passive RF device models. Creating designs, involves the following: 

 

i. Parametric Model Generation – creating the geometry, boundaries and 
excitations. 

ii. Analysis Setup – defining solution setup and frequency sweeps.  
iii. Results – creating 2D reports and field plots.  
iv. Solve Loop - the solution process is fully automated. 
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To understand how these processes co-exist, examine the illustration shown In Fig (11). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (11): Ansoft HFSS Desktop. 
 
 
 
 

8. Opening a HFSS project 
 

This section describes how to open a new or existing project. 
 

8.1  Opening a New project 
 

To open a new project: 
i. In an Ansoft HFSS window, select the menu item File > New.  

ii. Select the menu Project > Insert HFSS Design. 
 

8.2 Opening an Existing HFSS project 
 

To open an existing project: 
 

i. In an Ansoft HFSS window, select the menu File > Open. Use the Open dialog to 
select the project. 

ii. Click Open to open the project 
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Fig (12): Opening a HFSS project. 
 
 
 
 

8.3  To set the solution type: 

 

Select the menu item HFSS > Solution Type  

Solution Type Window: 
 

 Choose one of the following: 
o Driven Modal
o Driven Terminal 
o Eigen mode 
o 

 Click the OK button
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (13): Solution Type. 
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9. Overview of the 3D Modeler User Interface 
 

The following Fig (14) shows the 3D Modeler window. 

 

i. 3D Modeler Design Tree – The 3D Modeler Design Tree is an essential part of 
the user interface. From here you may access the structural elements in 
addition to any object dependencies and attributes.  

ii. Context Menus – Context menus are a flexible way of accessing frequently 
used menu commands for the current context. The contents of these menus 
change dynamically and are available throughout the interface by clicking the 
right mouse button.  

iii. Graphics Area – The graphics area is used to interact with the structural 
elements. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (14): HFSS 3D Modeler window. 
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When using the 3D Modeler interface you will also interact with two additional 
Interfaces: 

 

i. Property Window – The Property Window is used to view or modify the 
attributes and dimensions of structural objects is shown in Fig (15). 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (15): HFSS Property window. 

 

ii. Status Bar/Coordinate Entry – The Status Bar on the Ansoft HFSS Desktop 
Window displays the Coordinate Entry fields that can be used to define points 
or offsets during the creation of structural objects is shown in Fig (16). 

 
 
 

 

Fig (16): Status Bar/Coordinate Entry. 
 

 

10. Grid Plane 
 

To simplify the creation of structural primitives, a grid or drawing plane is used. 
The drawing plane does not in any way limit the user to two dimensional 
coordinates but instead is used as a guide to simplify the creation of structural 
primitives. The drawing plane is represented by the active grid plane (The grid does 
not have to be visible). To demonstrate how drawing planes are used, review the 
following section: Creating and Viewing Simple Structures. 

 

 

11. Creating and Viewing a Simple Structure 
 

Creating 3D structural objects is accomplished by performing the following steps: 
 

1. Set the grid plane 
2. Create the base shape of the object 
3. Set the Height 
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11.1 Create a Box 
 

We will investigate creating a box to demonstrate these steps. These steps 
assume that project and a HFSS design have already been created. Three points are 
required to create the box. The first two form the base rectangle and the third sets 
the height. 

 

Point 1: Defines the start point of the base rectangle 
Point 2: Defines the size of the base rectangle  

Point 3: Defines the height of the Box 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (17): Creating a Box using Status Bar/Coordinate Entry. 
 

 

I. Select the menu item 3D Modeler > Grid Plane > XY 
II. Use the mouse to create the base shape  

i. Set the start point by positioning the active cursor and click the left 
mouse button. 

 
 
 
 
 
 
 
 
 
 
 
 

 

ii. Position the active cursor and click the left mouse button to set 
the second point that forms the base rectangle. 
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iii. Set the Height by positioning the active cursor and clicking left 
mouse button. 

 
 
 
 
 
 
 
 
 
 
 
 
 

12. Specifying Points 
 
 

 

12.1 Grid 
 

From the example, we saw that the simplest way to set a point is by clicking its 
position on the grid plane. To set the precision of the grid plane, select the menu 
item View > Grid Settings. From here you may specify the Grid Type, Style, Visibility, 
and Precision. By pressing the Save as Default button, you can set the default 
behavior for future HFSS Designs. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (18): Grid. 
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12.2 Coordinate Entry 
 

Another way to specify a coordinate is to use the Coordinate Entry fields which 
are located on the status bar of the Ansoft HFSS Desktop. The position may be 
specified in Cartesian, Cylindrical, or Spherical coordinates. Once the first point is 
set, the Coordinate Entry will default to Relative coordinates. In Relative mode the 
coordinates are no longer absolute (measured from the origin of the working 
coordinate system), but relative to the last point entered.  

 Equations
 

o The Coordinate Entry fields allow equations to be entered for 
position values. Examples: 2*5, 2+6+8, 2*Cos (10*(pi/180)).  

o Variables are not allowed in the Coordinate Entry Field. 
o Note: Trig functions are in radians. 

 
 
 

 

Fig (19): Relative mode. 
 

 

12.3 Object Properties 
 

 By default the Properties dialog will appear after you have finished sketching 
an object. The position and size of objects can be modified from the dialog. 
This method allows you to create objects by clicking the estimated values 
using the mouse and then correcting the values in the final dialog.


 The Property dialog accepts equations, variables, and units. See the Overview 

of Entering Parameters for more detail.
 Every object has two types of properties.

o  Command – Defines the structural primitive 
o  Attributes – Defines the material, display, and solve properties 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (20): Command. 
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Fig (21): Attributes. 
 

13. Overview of Draw 
 

13.1 Snap Mode 
 

As an aid for graphical selection, the modeler provides Snap options. The default 
is to snaps are shown here. The shape of the active cursor will dynamically change as 
the cursor is moved over the snap positions. 

 

13.2 Moving 
 

 By default all active cursor movement is in three dimensions. The modeler can 
also be set to allow the active cursor to only move in a plane or out of plane. 
These are set from the menu item 3D Modeler > Movement Mode.


 In addition, the movement can be limited to a specific direction (x, y, or z) by 

holding down the x, y, or z key. This prevents movement in the other directions.


 Pressing the CTRL+Enter key sets a local reference point. This can be useful for 
creating geometry graphically that is based on an existing object.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (22): Moving. 
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14. Selecting Previously Defined Shapes 
 

You may select an object by moving the mouse over the object in the graphics area 
and clicking on it. The default mode is Dynamic selection which will display the 
object to be selected with a unique outline color. Please note that after selecting 
(Clicking on the object) the object it will be displayed solid pink while all other 
objects are drawn transparent. 

 

14.1 Types of Selection 
 

The default is to select objects. Sometimes is necessary to select faces, edges, or 
vertices. To change the selection mode, select the menu item Edit > Select and 
choose the appropriate selection mode. The shortcut keys o (Object selection) and f 
(face selection) are useful for quickly switching between the most common 
selections modes. 

 

14.2 Multiple Select or Toggle Selection 
 

Multiple objects can be selected graphically by holding down the CTRL key while 
selecting. In addition, with the CTRL key pressed, the selection of an object can be 
toggled between selected or unselected. 

 

14.3 Blocked Objects 
 

If the object you wish to select is located behind another object, select the 
object that is blocking the desired object and press the b key or right-click and select 
Next Behind from the context menu. You may repeat this as many times as needed 
to select the correct object. 

 

14.4 Select All Visible 
 

You can select all visible objects by pressing the CTRL+A key or by selecting the 
menu item Edit > Select All Visible. 

 

14.5 Select by Name 
 

To select objects by Name you can use anyone of the following: 

 Select the menu item Edit > Select > By Name.
 Select the menu item HFSS > List.

o Select the Model tab. 
 

o Select objects from the list. 
o Use the Model Tree. 
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14.6 Attributes 
 

 You may select an object by clicking on the corresponding item in the Model 
Tree.


 When the object is selected the attributes will be displayed in the Property 

Window. Double-clicking on the object will open a properties dialog. Use the 
Property Window or properties dialog to modify the attributes.



14.7 Commands 
 

 From the Model Tree, the Command Properties can be selected by expanding 
the object folder to display the command list. Using the mouse, select the 
corresponding command from the tree. The properties will be displayed in 
the Property Window. Double-clicking on the command will open a 
properties dialog. Use the Property Window or properties dialog to modify 
the command.


 When the command is selected, the object will be outlined with bold lines in 

the 3D Model Window. Since an object can be a combination of several 
primitives, the command list may contain several objects. Anyone of these 
commands can be selected to visualize or modify the object.

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig (23): Attributes & Commands. 
 

15. Object Attributes 
 

An objects attributes set the following user defined properties: 

 

 Name – User defined name. Default names start with the primitive type followed 
by an increasing number: Box1, Box2, etc.


 Material – User defined material property. The default property is vacuum. This 

can be changed by using the material toolbar.
 Orientation


 Solve Inside – By default HFSS only solves for fields inside dielectrics. To force 

HFSS to solve inside conductors, check solve inside.
 Model Object – Controls if the object is included in the solve
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 Display Wireframe – Forces the object to always be displayed as wireframe.

 Color – Set object color.


 Transparency – Set the transparency of an object. 0–Solid, 1- Wireframe. 
Note: Visibility is not an object property.
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (24): Ansoft HFSS Object Attributes. 
 

16. Materials 
 

By clicking on the property button for the material name, the material definition 
window will appear. You can select from the existing database or define a custom 
project material. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (25): Material Selection. 
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16.1 User Defined Project Material 
 

To define custom materials click the Add Material button from the material 
definition window. The following dialog will appear. Enter the material definitions 
and click the OK button. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Fig (26): User Defined Project Material. 
 

17. Changing the View 
 

You can change the view at any time (even during shape generation) by using the 
following commands: 

 

 

17.1 Toolbar 

 

 Rotate – The structure will be rotated around the coordinate system.

 Pan – The structure will be translated in the graphical area.


 Dynamic Zoom – Moving the mouse upwards will increase the zoom factor while 
moving the mouse downwards will decrease the zoom factor.


 Zoom In/Out – In this mode a rubber band rectangle will be defined by dragging 

the mouse. After releasing the mouse button the zoom factor will be applied.
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17.2 Context Menu 
 

Right click in the graphics area and select the menu item View and choose from 
the options outlined in the Toolbar section. The context menu also offers the 
following: 

 

 Fit All – This will zoom the defined structure to a point 
where it fits in the drawing area.


 Fit Selection – This fits only the selected objects into 

the drawing area.


 Spin – Drag the mouse and release the mouse button to 
start the object spinning. The speed of the dragging 
prior to releasing the mouse controls the speed of the 
spin.


 Animate – Create or display the animation of 

parametric geometry.
 
 

 

17.3 Shortcuts 
 

Since changing the view is a frequently used operation, some useful shortcut 
keys exist. Press the appropriate keys and drag the mouse with the left button 
pressed: 

 

 ALT + Drag – Rotate

 Shift + Drag – Pan
 ALT + Shift + Drag – Dynamic Zoom

 

 

Shortcuts - Predefined Views 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Fig (27): Predefined View Angles. 
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17.4 Visibility 
 

The visibility of objects, Boundaries, Excitations, and Field Reports can be 
controlled from the menu item View > Visibility. 

 

17.5 Hide Selection 
 

The visibility of selected objects can be set hidden by selecting the object(s) and 
choosing the menu View > Hide Selection > All Views. 

 

17.6  Background Color 
 

To set the background color, select the menu item View > Modify Attributes > 
Background Color. 

 

17.7 Addition View Settings 
 

Additional attributes of the view such as the projection, orientation, and lighting 
can be set from the menu item View > Modify Attributes. 

 

 

18. Applying Structural Transformations 
 

So far we have investigated hot to model simple shapes and how to change the view 
of the model. To create more complicated models or reduce the number of objects 
that need to be created manually we can apply various transformations. The 
following examples assume that you have already selected the object(s) that you 
wish to apply a transformation. You can select the transformation options from the 
menu item Edit > 

 

 Arrange >
o Move – Translates the structure along a vector.  

o Rotate – Rotates the shape around a coordinate axis by an angle. 
o Mirror – Mirrors the shape around a specified plane. 
o Offset – Performs a uniform scale in x, y, and z. 

 Duplicate >
o Along Lines – Create multiple copies of an object along a vector. 

 
o Around Axis – Create multiple copies of an object rotated by a fixed angle 

around the x, y, or z axis. 
 

o Mirror - Mirrors the shape around a specified plane and creates a 
Duplicate.  

 Scale – Allows non-uniform scaling in the x, y, or z direction

 

The faces of an object can also be moved to alter the shape of an existing object. To 
move the faces of an object select the menu item 3D Modeler > Surfaces > Move 
Faces and select Along Normal or Along Vector. 
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19. Combine Objects by Using Boolean Operations 
 

Most complex structures can be reduced to combinations of simple primitives. Even 
the solid primitives can be reduced to simple 2D primitives that are swept along a 
vector or around an axis (Box is a square that is swept along a vector to give it 
thickness). The solid modeler supports the following Boolean operations: 

 

 Unite – combine multiple primitives, Unite disjoint objects.
 Subtract – remove part of a primitive from another.

 Split – break primitives into multiple parts.

 Intersect – keep only the parts of primitives that overlap.


 Sweep – turn a 2D primitive into a solid by sweeping: Along a Vector, 
Around an Axis, along a Path.


 Connect – connect 2D primitives. Use Cover Surfaces to turn the 

connected object into a solid.
 Section – generate 2D cross-sections of a 3D object.

 
 
 
 
 

 

Fig (28): Unit, Subtract, Intersect, Split. 
 
 
 
 
 
 
 

 

20. LAB TASK 
 

Select any figure from internet and draw it in HFSS by using the above commands. 
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